Scheduled for May 31, 2022 at 6:32 PM – 8:03 PM
Affects
Survival Server
Under maintenance from 6:32 PM to 8:03 PM
Completed
May 31, 2022 at 8:03 PMCompleted
May 31, 2022 at 8:03 PMMaintenance has completed successfully.
In progress
May 31, 2022 at 6:33 PMIn progress
May 31, 2022 at 6:33 PMMaintenance is now in progress.
Planned
May 31, 2022 at 6:32 PMPlanned
May 31, 2022 at 6:32 PMWe are planning for a scheduled maintenance during that time.