Scheduled for October 06, 2021 at 12:04 PM – 12:37 PM
Affects
Survival Server
Under maintenance from 12:04 PM to 12:37 PM
Completed
October 06, 2021 at 12:37 PMCompleted
October 06, 2021 at 12:37 PMMaintenance has completed successfully.
In progress
October 06, 2021 at 12:04 PMIn progress
October 06, 2021 at 12:04 PMWe are planning for a scheduled maintenance during that time.